pub deps

Deps is one of the commands of the pub tool. Learn more about pub.

$ pub deps [--style=<style>]

This command prints the dependency graph for a package. The graph includes both the immediate dependencies that the package uses (as specified in the pubspec), as well as the transitive dependencies pulled in by the immediate dependencies.

The dependency information is printed as a tree, a list, or a compact list.

For example, the pubspec for the markdown_converter example specifies the following dependencies:

dependencies:
  barback: any
  markdown: any

Here’s an example of the pub deps output for markdown_converter:

$ pub deps
markdown_converter 0.0.0
|-- barback 0.11.1
|   |-- path 1.0.0
|   |-- source_maps 0.9.0
|   '-- stack_trace 0.9.2
|       '-- path...
'-- markdown 0.5.0

Options

For options that apply to all pub commands, see Global options.

--style=<style> or -s <style>
Optional. How the output should be displayed. The options are: compact, tree, or list. The default is tree.